Error Windowsbase Version 3.0.0.0

Posted by on November 14, 2012


Oh how I have not missed you little error message: “The application requires that assembly Windowsbase Version 3.0.0.0 be installed in the Global Assembly Cache first.

The first time I saw this I chuckled.  I went and looked up to confirm my suspicions and then … verifying I was on Widows 2008R2, I proceeded to my Server Manager>Features and add “.NET Framework 3.5.1 Features”  accept defaults (add required role services>next>next>next>install) reboot>patch>reboot and done.  Your issue is resolved.

HOWEVER, if you have come here, and you find you have .NET 3.5.1 role already installed, go ahead and uninstall>reboot>follow the above … there now isn’t that better?


ChatClick here to chat!+